Hoje fiz uma atualização de segurança do Ubuntu, não que eu sempre veja mas dessa vez eu nem passei o olho para saber o que se passava. Isso é um grande erro.
Essas atualização incluiam o pacote linux-restricted-modules-2.6.24-19-generic, feito todas as instalações pediu para reinciar o computador. Poxa mas isso é linux ou Windows? Me perguntei. Logo veio a resposta realmente estão reproduzindo o windows no Ubuntu. Resultado parcial, parou de funcionar minha rede sem fio e minha placa de som nem olhei o resto.
Vamos aos passos para sabermos o porque do não funcionamento.

Digite o comando
dmesg.

Com este comando eu visualizo as mensagens de carregamento do sistema, com muita paciência fui vendo linha a linha até encontrar algo que me parecece (é assim que se escreve?) estranho.
Achei a linha WL com uma mensagem de Fatal erro. Vamos ao passo dois que é copiar essa string (linha de palavras) e entrar no tio google para saber se alguém já teve esse problema.
Achei milhares de coisas relacionadas e algumas que não tinham nada haver.
Minha máquina é um notebook Inspiron 1525 da fabricante Dell, sendo assim sempre procurava entrar nas palavras relacionadas. Minhas palavras chaves eram Ubuntu, Inspiron, Dell, E o erro encontrado como saida do dmesg.
Achei um forum muito interessante em que alguém tinha o mesmo computador que o meu e o problema exatamente igual. Descobri que a Dell também tem um site com informações de ajuda e da comunidade.
Resumindo a historia pois já escrevi muito. Para que minha placa de som e Wireles voltasse a funcionar tenho que voltar a versão do linux-restrict. Fui no menu sistema->administração->Gerenciador de Pacotes Synaptic, e verifiquei as versões que existiam. Para meu espanto existia três versões do mesmo pacote só não sei para que.
Vamos resolver o problema, desinstalei todos os pacotes que não queria e deixei apenas o que realmente me interessava. Reinicie e no menu do Grub fui até a versão do linux-restrict 18 no modo recovery e pronto. Instalei a versão que estava funcional.
Para ter certeza que a versão errada não seja chamada novamente desinstalei a versão mais nova também. Agora com o sistema limpo e funcional fui no google de novo para saber a última informação.
E se este pacote defeituoso voltar a ser instalar no meu sistema? Existe uma flag que podemos adicionar ao comando aptitute para que esse pacote não seja atualizado sozinho. Não sei se funciona mas fiz o seguinte.

sudo aptitude hold linux-restricted-modules-2.6.24-18-generic
sudo aptitude hold linux-restricted-modules-common

Após essa longa jornada, só como detalhe perdi 3 horas fazendo todas essas tentativas, mandei o synaptic verificar por atualizações e ele respondeu que o sistema se encontrava com a versão mais recente. Então conclui que tudo estava direito e funcionando e o pacote com erro não entraria no meu sistema por discuido de não olhar o que vai ser instalado.

Ubuntu não vire windows, senão vou abandona-lo e vou voltar para FreeBSD.

Tags: , , , , , ,